Wordpress Cronjobs giving off "Too Many Redirects" errors

Hi everyone,
I’m having a really strange issue with my website. I noticed a lot of cron jobs stacking up in the Status tab of WooCommerce. After installing WP Crontrol to check the Cron jobs it says the following issue is present for cron jobs:

There was a problem accessing the WP-Cron system on your site. This means that WP-Cron events on your site may not work. The problem was:

Too many redirects

I’m running on CloudPanel.io (Debian 10 on a VPS). I also have Cloudflare.

Anyone know how I can fix this because I have no idea where to start…

Kind regards, Roel

You can fix “Too many redirects” error on WordPress by:

  1. Clear browser cookies and cache.
  2. Clear your caching plugin.
  3. Disable your plugins.
  4. Check URL settings.
  5. Reset .htaccess file.
  6. Check domain settings.

Hi, I’ve already tried the most common things.
Do you have any other idea what the solution could be?

Furthermore, do you see thoes requests from your server IP when at Firewall Events you navigate to the Firewall tab → Overview at Cloudflare dashboard? :thinking:

Just in case, I’d suggest to add your server IP to the Security → Tools → IP Access Rules with the action “allow” for your website.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.