Wordpress cron, SSL and Cloudflare

I have a wordpress e-commerce website.
It linked to my cloudflare and I activated the traffic via cloudflare.

I’m using a VPS Centos server. To my surprise the default web ports are different there: 8080 for HTTP and 8443 for HTTPS.

So, when I run my cron of WP I see this:

cURL error 7: Failed connect to chicbag.boutique:443; Connection refused

When I run telnet 443 I see the same - connection refused.
As I know we can have Connection refused error when the firewall blocks it or it’s opened, but there are no listeners. In my case it’s opened and apache doesn’t listen to it.
I tried to redirect all requests from 443 to 8443 port, but then I get:

SSL received a record that exceeded the maximum permissible length

WP cron somehow works with POST requests and it sends a POST to wp-cron.php file, but as there is SSL unabled, it cannot work.

What should I do?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.