Wordpress.com - Cloudfare - To many recdirects

We configured our Wordpress.com pages ciokurator.com (primary site address) and ciokurator.de for Cloudfare. Everything was asking, but this morning we were not able to open the site. Error message too many redirects. Deleting cache and cookies didn’t help.

SSL is on flexible. HTTPS is always on.

Where could the problem be.

  • The com’s name server is wordpress.
    ** The de’s name server is United Domains.

That’s your issue. You selected an insecure encryption mode which not only kept your site on HTTP but is also the reason for the error.

Switch to Full Strict and your site should load fine.

Thx sandro. I will give a try. One of the installation documents recommended flexible … Now it works.

Yeah, unfortunately there is quite a lot of misinformation out there.

1 Like

Thx again. My challenge is that in the combination Wordpress.com with sub-domain, Cloudfare and the Newsletter-service Getrevue it looks like Getrevue requires the SSl flexible mode to support https.

When setting the domain to flexible, the newsletter service is on https.
When setting it to Full (strict) I get the error

Error 525

Ray ID: 70dc52031ac79214 • 2022-05-19 10:58:57 UTC

SSL handshake failed

In that case I’d pause Cloudflare (Overview screen, bottom right), fix the server to have it work on HTTPS, and only then unpause Cloudflare.

A 525 means that you do not have a proper SSL setup and only your host can fix that.

The question is do you want everything on HTTPS? If not, you could disable the HTTPS redirect.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.