Wordpress.COM cannot access website when Cloudflare is active


#1

Hi everyone. I have following issues with a self-hosted site when Cloudflare is active:

  1. When I try to use WordPress dot COM on a browser or the app on my cell phone, I get this message “This site cannot be accessed”. Therefore, I can’t see updates for blog posts nor for pages in WordPress.Com neither WordPress app.

  2. WordPress dot ORG sharing connections for Facebook, Twitter, etc. don’t work (under Settings/Sharing). I get this message “Something which should never happen, happened. Sorry about that. If you try again, maybe it will work. Error code: -32601”

I already contacted WP support, but they couldn’t find a solution.

However, when I pause Cloudflare, my website can connect correctly to WP dot COM and I can connect to social media via Publicize under Settings/Sharing.

By the way, Rocket Loader is off.

Does anyone have a solution for this?

Regards,

AJ


#2

Hi @alvin_azocar, what does jetpack support say about what their error code actually means? I’m not familiar with the error.

(Shot in the dark until we learn more from jetpack -> are jetpack IPs blocked?)


#3

Hi. Thank you for the reply.

After my comment, I kept looking and I found this:

Use Jetpack and Cloudflare on your WordPress site

I used only following steps:

  • Create a PageRule to exclude WordPress’ dashboard from Cloudflare. Actually, I changed my PageRule regarding wp-admin.

  • Install the Cloudflare Flexible SSL plugin to avoid running into Redirect loop issues in your dashboard.

Other steps were not required.

Problem solved!

However, I don’t understand why Jetpack / WordPress support couldn’t guide me that information.

Regards,

AJ


#4

Actually, the problem hasn’t been solved.

Now,

  1. Slider Revolution isn’t working; it isn’t shown at all on pages where Slider Revolution is used.

  2. I think I got in a loop as a plugin needs update. I update it, but I keep seen the update request.

So, I followed these steps from Jetpack support:

  1. Install and activate the Cloudflare plugin.

  2. Enable Administration over SSL by adding the following to wp-config.php :

    /**

    * Admin over SSL

    */

    define( 'FORCE_SSL_ADMIN' , true);

6 Set the port to 443 by adding the following to wp-config.php :

/**

* Set port to 443

*/

$_SERVER [ 'SERVER_PORT' ] = 443;

  1. ** This was already implemented ** Under Settings/General in your dashboard, change both your site address and WordPress address to use HTTPS.

8 In your Cloudflare settings, create a Page Rule to redirect all traffic from HTTP to HTTPS.

I know that the PageRule needs time to deploy.

I’ll see what happen in the next hours.

Regards,

AJ


#5

Hi.

Update. Problems solved!

Loop with the plugin update ended a few hours after applying the above-mentioned changes.

Slider Revolution is working, but this was after installing an update of W3 Total Chache.

Regards,

AJ