Wordpress + cloudflare


#1

hello to everyone,
i use cloudflare since 4 weeks everything is ok but in some pages i have some problem like this


completly blank, if i purge the page i see it…
afet some days will be blank… again

thanx fo your support


#2

For https version of your website there is a 301 error (moved permanently).

What is the output of the following command?

curl --silent --verbose http://www.iyezine.com/la-curiosita-uccise-gatto-salvo --resolve http://www.iyezine.com:80:a.b.c.d --insecure

Replace a.b.c.d with your server IP address (you can find it in your Cloudflare panel, DNS management, in front of A record).

Also try disabling any cache plugin you have on your server.


#3
  • Couldn’t parse CURLOPT_RESOLVE entry ‘http://www.iyezine.com:80:95.241.159.65’!
  • Trying 104.31.85.6…
  • TCP_NODELAY set
  • Connected to www.iyezine.com (REMOVED) port 80 (#0)

GET /la-curiosita-uccise-gatto-salvo HTTP/1.1
Host: www.iyezine.com
User-Agent: curl/7.53.0-DEV
Accept: /

< HTTP/1.1 200 OK
< Date: Mon, 04 Sep 2017 17:22:43 GMT
< Content-Type: text/html; charset=UTF-8
< Transfer-Encoding: chunked
< Connection: keep-alive
< Set-Cookie: __cfduid=d327578272e735dc12312c756a98d65071504545763; expires=Tue, 04-Sep-18 17:22:43 GMT; path=/; domain=.iyezine.com; HttpOnly
< X-Powered-By: PHP/5.6.31
< Link: http://www.iyezine.com/wp-json/; rel=“https://api.w.org/”, http://www.iyezine.com/?p=61495; rel=shortlink
< CF-Cache-Status: HIT
< Server: cloudflare-nginx
< CF-RAY: 3992a1ee8298579b-IAD
<

La curiosità uccise il gatto e salvò me. - - 29 agosto 2017 @font-face {font-family: "sw-icon-font";src:url("http://www.iyezine.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.eot?ver=2.3.2");src:url("http://www.iyezine.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.eot?ver=2.3.2#iefix") format("embedded-opentype"),url("http://www.iyezine.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.woff?ver=2.3.2") format("woff"), url("http://www.iyezine.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.ttf?ver=2.3.2") format("truetype"),url("http://www.iyezine.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.svg?ver=2.3.2#1445203416") format("svg");font-weight: normal;font-style: normal;}

#4

Please remove your IP address.

Do you have any routing rules in your .htaccess file? can you share it?


#5

my htaccess…

Options +FollowSymLinks
RewriteEngine on
RewriteCond %{HTTP_HOST} ^iyezine.com
RewriteRule ^(.*)$ http://www.iyezine.com/$1 [R=permanent,L]

order allow,deny

Wordfence WAF

<Files “.user.ini”>

Require all denied

<IfModule !mod_authz_core.c>
Order deny,allow

END Wordfence WAF

BEGIN WordPress

RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L]

curl --silent --verbose http://www.iyezine.com/la-curiosita-uccise-gatto-salvo --resolve http://www.iyezine.com:8 --insecure

GET /la-curiosita-uccise-gatto-salvo HTTP/1.1
Host: www.iyezine.com
User-Agent: curl/7.53.0-DEV
Accept: /

< HTTP/1.1 200 OK
< Date: Tue, 05 Sep 2017 08:18:47 GMT
< Content-Type: text/html; charset=UTF-8
< Transfer-Encoding: chunked
< Connection: keep-alive
< Set-Cookie: __cfduid=dd8928c2ccee35f5cd4d498284a7a72361504599524; expires=Wed, 05-Sep-18 08:18:44 GMT; path=/; domain=.iyezine.com; HttpOnly
< X-Powered-By: PHP/5.6.31
< Link: http://www.iyezine.com/wp-json/; rel=“https://api.w.org/”, http://www.iyezine.com/?p=61495; rel=shortlink
< CF-Cache-Status: EXPIRED
< Server: cloudflare-nginx
< CF-RAY: 3997c272a7ec246e-IAD
<


#6

Backup your .htaccess and replace it with these lines:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

#7

i do nothing change :frowning:


#8

Since the problem is with just few pages, it is on your side (except you have wrong page rules in CF panel) and nothing more than routing or cache plugin comes to my mind.
If you have a recent update on some plugin/theme is worth disabling it and check again.


#9

i check all the plugin nothing changed some pages just like



when i click to start caching disappera not error but simply blank…
please help me :slight_smile:
thanx