Wordpress Automatic Platform Optimization is not getting activated

I’ve setup Cloudflare plugin in our wordpress site. And as per the documentation also removed the Rocket-WP cache plugins. Its been more than a week. The Cloudflare dashboard couldn’t find cloudflare plugin in our site: varicon.com.au
Note: The WordPress plugin was not detected on varicon.com.au.

While plugin has been installed for weeks and also logged in using API token with appropriate permission enabled.

Currently the headers respond on GET request is
HTTP/2 200 date: Tue, 13 Feb 2024 06:10:18 GMT content-type: text/html; charset=UTF-8 cf-edge-cache: cache,platform=wordpress link: <https://varicon.com.au/wp-json/>; rel="https://api.w.org/" link: <https://varicon.com.au/wp-json/wp/v2/pages/18>; rel="alternate"; type="application/json" x-frame-options: SAMEORIGIN x-xss-protection: 1; mode=block x-content-type-options: nosniff referrer-policy: no-referrer-when-downgrade content-security-policy: default-src 'self' http: https: data: blob: 'unsafe-inline' http: https: data: blob: 'unsafe-eval' strict-transport-security: max-age=0; includeSubDomains cf-cache-status: DYNAMIC report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=AG3%2BLYVU1fn96u6Xo%2FMciP0GkJXSp15Rnoj1fZ0Z%2FYHnOCdPxDnywRtCERfbdj89%2BLyDjZeKprcnUtN%2B91xq9LcljmJuknuQqWOdzxI4Q0j%2BAjA4xnIh9IAC1A%2FfAHEg"}],"group":"cf-nel","max_age":604800} nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800} server: cloudflare cf-ray: 854ae84ba84e790d-KTM

What have I been missing here?

I found the solution for the problem. It was actually due to my Nginx server disabling PATCH request.

Solution: Enable PATCH request to wp-admin/admin-ajax.php?action=cloudflare_proxy

It looks to be working now:

> GET / HTTP/2
> Host: varicon.com.au
> user-agent: curl/7.68.0
> accept: */*
> 
{ [5 bytes data]
* TLSv1.3 (IN), TLS handshake, Newsession Ticket (4):
{ [230 bytes data]
* TLSv1.3 (IN), TLS handshake, Newsession Ticket (4):
{ [230 bytes data]
* old SSL session ID is stale, removing
{ [5 bytes data]
* Connection state changed (MAX_CONCURRENT_STREAMS == 100)!
} [5 bytes data]
< HTTP/2 200 
< date: Tue, 13 Feb 2024 14:29:50 GMT
< content-type: text/html; charset=UTF-8
< cf-ray: 854dc40c2d392f43-LAX
< cf-cache-status: HIT
< age: 3
< cache-control: max-age=14400
< last-modified: Tue, 13 Feb 2024 14:29:47 GMT
< link: <https://varicon.com.au/wp-json/>; rel="https://api.w.org/", <https://varicon.com.au/wp-json/wp/v2/pages/18>; rel="alternate"; type="application/json"
< strict-transport-security: max-age=0; includeSubDomains
< vary: Accept-Encoding
< cf-apo-via: tcache
< cf-edge-cache: cache,platform=wordpress
< content-security-policy: default-src 'self' http: https: data: blob: 'unsafe-inline' http: https: data: blob: 'unsafe-eval'
< referrer-policy: no-referrer-when-downgrade
< x-content-type-options: nosniff
< x-frame-options: SAMEORIGIN
< x-xss-protection: 1; mode=block
< report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=M7umY0v5Yi6hKEqOMuyfP%2BqMmsTFaJDnws0YAjB3HRr6YIEPenmAfs1MRzpw8T%2B38UA8JpMUh6HUHZaPuH43KiqTLl9ljAyh%2BvmiIqkIAbFC6boUq7clTSs4V0vWaF7q"}],"group":"cf-nel","max_age":604800}
< nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
< server: cloudflare