Wordpress and Cloudflare - icons are not shown anymore

#1

Hi there,
I am using cloudflare with wordpress. With CDN enabled, the icons for “seach + shopping cart + settings” on the top menue bar are not shown anymore - the KinComposer icons in the text are not shown anymore too and also the “right/left” arrows of RevolutionSlider.
When I deactivate CDN the icons are back again.
What can I do? What do I make wrong?
Thank you in advance.
BR
Leng

#2

Domain?

#3

Good Morning Sandro,

you are very quick :slight_smile:

Sorry for may late answer. Due to system requirenments, I was not able to reply earlier. As this is my second post, my account was temporarily placed on hold until a staff member has reviewed my posts.
Now I am back again.

Here are the the demains:
patesco.de (CDN active)
patesco.eu (CDN inactive)

Greetings Leng

#4

I am not sure what you mean by active and inactive but both domains go via Cloudflare.

Generally though, that is a CORS issue not a Cloudflare one :slight_smile:

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://patesco.eu/wp-content/themes/goral/fonts/monia.ttf?blahfl. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).

You either have to configure the respective header for your .eu domain or need to load the font from each domain individually instead of sharing it.

#5

Dear Sandro,
I tried this code in .htaccess (and several others for .htaccess and fuctions.php):
<FilesMatch “.(ttf|otf|eot|woff)$”>

Header set Access-Control-Allow-Origin “patesco.de


… but unfortunately without success.
Do you have any suggestion?
Thank you in advance.
Greetings Leng

#6

Try clearing your Cloudflare cache.

#7

… hmm. I have to insert spacers to display all the code???
<FilesMatch “.(ttf|otf|eot|woff)$”>
< IfModule mod_headers.c>
Header set Access-Control-Allow-Origin “patesco.de
</ IfModule>
</ FilesMatch>

#8

I cleared the cache on WordPress and on Cloudflare (purged)

#9

In that case I’d take this to an Apache related forum. Something in the configuration is off, the header is not sent yet.

#10

OK. I will ask my hoster as he deals the Apache part.
Thank you so far.

#11

I got the feedback of my hoster, that now he has activated mod_headers:“headers_module (shared)” but the problem is not solved. Do you guess watt else I can do?

#12

You currently have the header configured twice. That might be a problem.

#13

You are so quick!!
Twice? How can I check that by myself?

#14

Somewhere in your configuration.

#15

OK for sure :blush:
But how could you see that it is configured twice?

#16

:slight_smile:

1 Like
#17

I see. Because I have no access on the apache, only my hoster is able to, I will have to wait until he has fixed the problem. Your hints helped me to make him him working on it. Thank you.

closed #18

This topic was automatically closed after 31 days. New replies are no longer allowed.