Wordpress Admin login gives Error 526


When trying to log in to my WP site, I get an Error 526 (Invalid SSL certificate).
The front end seems to work fine, but I can not log in.
Not sure why this happened. I didn’t change anything.

This is my site: https://culturematters.com


Error 526: invalid SSL certificate

Error 526 occurs when these two conditions are true:

  1. Cloudflare cannot validate the SSL certificate at your origin web server, and
  2. Full SSL (Strict) SSL is set in the Overview tab of your Cloudflare SSL/TLS app.


For a potential quick fix, set SSL to Full instead of Full (strict) in the Overview tab of your Cloudflare SSL/TLS app for the domain.

Request your server administrator or hosting provider to review the origin web server’s SSL certificates and verify that:

If the origin server uses a self-signed certificate, configure the domain to use Full SSL instead of Full SSL (Strict) . Refer to recommended SSL settings for your origin.

1 Like

If you Clear cache then your frontend also won’t work.

Make sure you check the SSL configuration and get the certificate from cloudflare dashboard if possible


Thanks for the tips.
I got it back to work.
However, according to my knowledge, I don’t have any other SSL certificate active/installed on my site.
I only use CF to provide an SSL certificate.

So, how can this happen all of a sudden, after months of being very stable?
My host is Digital Ocean.


Before moving to Cloudflare, was your Website working over HTTPS connection?
If so, did you had an valid SSL certificate installed at your origin host / server which covers both your naked (root) domain any any other needed sub-domain like www, mail, etc.?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Was your WordPress website configured to work over HTTPS?
Did you used www or non-www URL address to access?
Furthermore, in terms of a WordPress admin dashboard, was it working only over the SSL?

1 Like

Then it might be an issue with the certificate, check for the following

  • That the certificate NOT self-signed
  • That the certificate hasn’t been revoked accidentally (in any sort of way)
  • That the certificate has not expired
  • That the certificate is trusted

Alternatively, you may not have “Full (Strict)” enabled.

If you don’t have “Full (Strict)” enabled, then you should enable it in the overview page of your SSL/TLS settings in your Cloudflare dashboard!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.