Wordpress Admin Bar Shows To Visiting Users

I had a customer contact me today saying my wordpress admin bar shows to visitors. I went to a new device that I was not logged into and they were correct. When I disabled Cloudflare the issue was resolved. What is causing this issue. The site is methodprinting.com but Cloudflare remains disabled so you won’t see the issue at the moment.

Hi @brigham are you still seeing this? Just visited in incognito mode and it looks great, no admin options showing. Perhaps clear cache?

I had the website in developer mode which seemed to fix the issue on my end but it’s not a permeant fix obviously. I had my hosting company try a few things on their end to fix the issue as well as switching the site from http to https. They just finished and I turned off developer mode and it looks like it is resolved. If you have a sec can you check on your end again now that the sites switched over and developer mode is off?

You probably have a Page Rule set to Cache Everything. So if it caches the page with an Admin logged in, it will cache the Admin bar as well. And maybe some other stuff you don’t want cached as well.

1 Like

Hey. That sounds like it might be the issue. How would I resolve that if that is the case.

Disable that Page Rule. Or work around it in some/all of the following the ways:

  1. Set your Wordpress User to not show the Admin Bar when visiting the site.
  2. Don’t surf your site while logged in (use an Incognito browser)
  3. Put your site into Dev Mode when working on it.
  4. Purge the cache whenever you’re done working on it.
2 Likes

Make sense, thanks for your help.

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.