Wordpress Admin bar disappears when Cloudflare is enabled

When I have Cloudflare enabled for my Wordpress site, the admin bar doesn’t appear at the top. If I disable Cloudflare, the admin bar appears.

If I manually type in the admin address, I’m able to access my admin area without issue. But I guess it is showing me the cached version of the site even though I’m logged in.

Any assistance on how to fix this would be appreciated. Thanks.

Cloudflare won’t cache that by default. Have you changed any caching settings with Page Rules or Cache Rules?

1 Like

I have no Cache rules, but I do have 3 page rules:

I just deactivated them (as shown above) and purged my cache. That seems to have done the trick. Which rule was causing the problem?

I’ve switched to a plugin that suggests Workers instead of Page Rules. Is that best practice?
Any further information would be appreaciated!