Wordfence Scan Being Blocked

For some reason when we pause CF the WF Scan works and when enabled it does not.

  1. I have checked all firewall rules in CF and all IP are whitelisted
  2. I have checked server IP addresses and none of them are being blocked
  3. I have added the CF IP rules in NGINX server

I have also researched all topics in the community. Is there anything else that I am missing?

Good, meaning set_real_ip_from are being placed into the Nginx.conf.

May I ask have you selected CF-Connecting-IP option in Wordfence interface?

This option should correct the IP detection on your site and allow Cloudflare to work correctly with Wordfence.

Try to run a scan after you set this setting, and it should complete.

What error do you see at Cloudflare Firewall Events, if any appear?
Possible if so, your server IP would apper (you can add it and whitelist/allow/bypass it).

1 Like

Can you be more specific? Does the scan even start?

There’s a Wordfence option in Tools → Diagnostics for “Start all scans remotely”. And there’s also an option to enable Debugging which should a verbose output in the scan window.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.