WooCommerce - Zapier REST API


I have WooCommerce Zapier plugin running on our Wordpress site. I have a particular Zap to add coupons to Woo when a form is submitted in WP.

If I run/test the Zap from within Zapier then they always go through Ok. If I then turn on the Zap, when it runs automatically it fails constantly and reports the faults back as 401 but the return comes from Cloudflare, not our website. I have set up Firewall rules / Page rules to bypass the cache & firewall for the REST endpoints however it appears that the Cloudflare firewall is still interfering as the 401 response still comes from Cloudflare’s servers.

I have contacted support at both Zapier & the plugin developers and they all tell me that the issue is with Cloudflare. What is unusual is that if I run re-run the failed Zaps from within the Zapier dashboard then they all go through without issue??!

Hope someone can help.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.