WooCommerce Social Login plugin


Brand new out here, scary new world full with experts, please accept me to your community. Have Cloudflare caching question… This is what I was given by WC…

"WooCommerce Social Login has detected a problem with your hosting configuration that prevents some customers from linking a social account. For Social Login to function as expected, please follow the guidelines here, as your host must fix your site’s caching rules to exclude wp_woocommerce_session* cookies from caching._

My site runs the WooCommerce Social Login plugin and we are having some issues with signing in with our social providers and the current caching configuration. The developers of the plugin have asked us to place a cache exception for the /wc-api/ endpoint and the wc-api query argument, along with ensuring that wp_woocommerce_session* cookies are not cached. Could you please add the following URL to the exception list? http://YOURSITE.com/wc-api/* and also exclude anything using the wc-api query parameter from caching as well, such as http://YOURSITE.com/?wc-api&auth=twitter? Along with this, please ensure we’re excluding all session cookies using wp_woocommerce_session*? The session cookie caching is particularly problematic, as this is what causes the most login issues."

I am not sure exactly what Page Setting rules to apply. Any help very much appreciated.


Create 2 rules:
Enter http://YOURSITE.com/wc-api/* and choose Cache Level: Bypass
Enter http://YOURSITE.com/?wc-api* (wildcard covers use of wc-api query param) and choose Cache Level: Bypass

You will need a CloudFlare Business plan in order to effect the Bypass Cache on Cookie functionality also required by WooCommerce Social Login. Instructions for that setup are the same as for Magento https://support.cloudflare.com/hc/en-us/articles/236168808-Caching-Static-HTML-with-Magento-version-1-2-


Thanks matthew2, $6/mth seems ok I guess for he business plan, i put int he other rules but WC still complaining. Will keep experimenting.

closed #4

This topic was automatically closed after 14 days. New replies are no longer allowed.