Windows WARP Client - Freezing the entire home network

Turning on a WARP client on Windows (normal WARP or Zero Trust WARP not or Zero Trust DoH) causes all devices on the network to disconnect from it and are not able to reconnect until the client is turned off.

Windows Version: Windows 10 Pro 21H2 19044.2130
WARP Version: 2022.9.583.0
Cloudflare Diagnostic Output ( Cloudflare Diagnostic Tool

Hello there,

Have you checked using this solution before?

In case of WARP status, you can always find it here:

From what I deduced from this topic, the version I gave should be already working, but for me this version causes the same error ( KB5018410 installed and purging the cache did not help).
And if I understand correctly, the problem in this topic was only with the computer with client. In my case, the running WARP client grounds the entire home network.

Hi @Bartek20,

Well, that’s one more test point we can discard :slight_smile:

It appears your issue is not with CF WARP, rather with your service provider and/or router settings. Have you checked that? Have you contacted your Service provider?

Many times, router updates can cause what your described.

Also, since CF WARP is installed at a device level (not network level), have you tried to disconnect CF WARP from one device to see if that device works without it?


I am having problems with Windows client as well for the last 2 months. Internet is super slow when VPN enabled

The case is that everything works properly (the entire home network) until I run the WARP client on the PC, then suddenly all home and multimedia devices lose their connection as if it was jammed (there is no network access, and no possibility to connect to the router). The problem ceases after I disable the WARP client.
I would like to add that when you turn on the WARP client on Android, everything works fine.

Hi @Bartek20,

Did you try the following:

(1) Reinstall CF WARP.
(2) Reset CF WARP’s Encryption Keys and/or All Settings.
(3) Reset your internet connection.
(4) Check your local hosts file.
(5) Contact your service provider.

Beyond the above, I can’t of anything else at this time. If none of the above works, then delete CF WARP. It’s not a huge deal, no huge benefits in using it anyway :slight_smile:

Best wishes!

After many attempts, installing older versions, I was able to find a solution. When all methods failed, I decided to check if the router’s factory settings would be successful.
I made a backup of the settings and reset the router to factory settings and it worked. So I started to look for which setting causes the problems described above.
It turned out that activating the QoS function and giving the computer a higher priority on the network makes the whole network crash.
So if someone has a similar problem to me and has access to the router configuration, check if you have QoS turned on and if so, check if turning it off makes the problem disappear.
And thanks @Aviator for helping me solve the problem.

1 Like

Hey @Bartek20,

Glad I was able to help solve your issue.

Happy navigating!