Windows RDS Web App Cannot Connect

I dont actually know where to ask this question - however.
I am trying to secure a Windows Remote Desktop Application server behind Cloudflare Zero Trust. I have the application created, and the tunnel working. I can successfully browse to the website, my Cloudflare policy works, etc., etc.
What doesn’t work are the apps - they only use port 443, so I dont see how there is any configuration change needed in Cloudflare, but maybe? I have tried a number of different changes on my RD Gateway - I keep hitting the same issue of the app not working.
If I remove all of the Cloudflare configuration then the RD Web Apps works again as expected - they just don’t work their the proxy/tunnel.
I am happy to provide more details on the troubleshooting I’ve done thus far, but what I was really hoping for was a little direction from someone who has set this up successfully.
I’ve seen lots of post and tutorials on getting just RDS to work, most of them require WARP, but I really just want RD Web Apps to work they way they are intended without any agent or end-point configuration.
Thanks in advance…

This is the error I get when launching an RD Web App
Remote Desktop Connection
The remote resource can’t be reached. Check your connection and try again or ask your network administrator for help.

[Expanded Information]
Error code: 0x300000d
Extended error code: 0x0

Did you ever get this to work? I’m trying out the exact same thing and getting the same errors. I saw someone suggest using tcp://ipaddress:443 as the local service when defining the public hostname. This breaks the rdweb site and doesn’t allow the remote apps to launch. (I do get a login prompt) Changing tcp to https allows the rdweb site to show, but apps still do not launch. I did a pcap and saw that the proxy is closing the connection. I’m not sure what to change to correct this.

No, unfortunately I was not able to get this to work - I gave up on Cloudflare for this specific scenario. I ended up just putting the RD Web Apps behind a firewall and VPN - Which sucks a little bit for the end-users, but it is what it is.

Hi, I wanted to ask the same question to you; were you able to get this to work in any way? I’d hate to give up on this method as well, since it’s one of the big draws we had towards Cloudflare, but I’m running out of ideas to troubleshoot.

No, I gave up - I tried reaching out to Cloudflare but they were unwilling to offer any technical assistance without a paid subscription - I would have been happy to pay for a subscription if I at least had a working Proof of Concept, which is what I asked for, but again, the technical team was unwilling to help, though the sale team had lots of time to spend with me lol