Windows Admin Center Cloudflare tunnel not working

I have setup WAC on CF tunnels and it works from the aspect that I can reach the portal and log in however after login it is stuck at starting windows admin centre. All other connections work it’s just when using CFT it gets stuck on this page.

I have enabled various settings to no avail but have to use the No TLS Verify other I cannot reach it. tried https2 to no avail. I not sure why and any ideas appreciated.

Are you able to capture a HAR file of the issue?

Have you tested this locally ensuring the issue only occurs over the tunnel?

HAR file i haven’t as yet tried.
Yes, please assume it’s all been tested locally as mentioned “all other connections work” e.g. internal IP:port and hostname.domain:port,

thank you.

Same issue for me. Works fine locally, over a VPN or even with the Warp client. But setting it up as public host and I get the same Starting Windows Admin Center screen.

Is this a web Application? If so can you check the Developer Tool console for any errors? I am having similar issues with a Blazor app where it works fine behind the tunnel, but fails Infront of the tunnel.

My issue was related to minification of the HTML that was stripping comments that the app relied on. After disabling that it started to work.

I have noticed that Rocket Loader is interfering with script loading and the verification from TLS settings.

I disabled it with page rules, but now I have a 400 error message:

1 Like

Experiencing the same challenge. Has anyone figured out a solution for this?

I’ve also been facing this error, I believe it is something to do with the NTLM authentication header. I can get a 401 when connecting via cloudflared but a 400 when trying to properly authenticate against it.

it’s been a while and still no resolution dammm

Do we have any resolution on this. Thanks!