Windows 10: "No internet, connected" + “DNS server is not responding“

A few weeks ago I started having a Wi-Fi issue with all of my computers - but not all at the same time.

I’d be connected fine and suddenly I’d get a yellow ! on the Wi-Fi icon; and my Wi-Fi connection, instead of “connected, secured” would show “No internet, connected.” Multiple attempts to reconnect would fail.

But the problem only ever affected Windows 10 devices - and usually only one device at a time. My phone, TV, and other conneced devices were never effected, and other nearby Windows 10 devices were connected fine. Then later that day or the next, I’d experience the same problem with a different Windows 10 computer.

The error wasn’t timed to a Windows update. I tried updating the network adapter’s driver. I also tried a few other suggestions I found online, but nothing work. The only thing that fixed the issue was opening a command prompt and flushing the DNS cache. But I’d sometimes have to do that several times a day, and then on one PC even that stopped fixing the problem.

Finally, I switched form Cloudfare DNS to Google DNS and I’ve been two weeks without a problem.

I haven’t been able to find anything online to explain.

1 Like

A non-working resolver setup will not cause a “No Internet” message in the task bar. I haven’t seen that before, but since it’s Microsoft…

Where was 1^4 set? On your router and assinged via DHCP, or did you set it manually on the clients?

1 Like

I tried it both ways. Originally it was on the router, assigned via DHCP. After I started having trouble, I changed and set it locally which didn’t seem to help.

RE: Microsoft. I’ve seen a few things online about DNS issues with Windows, but nothing that sounded like the problem I’m having. I also checked Realtek and Asus (WiFi card and router) and couldn’t find anything there either.

Of course, it’s WiFi, so any of 100 things could being causing interference. But it only affects one PC at a time, and there appears to be good signal strength. So I haven’t focused on that. Especially since clearing the DNS cache fixed the problem temporarily.

The weirdest part is that the problem seems to have stopped after switching to Google DNS.

Given my luck, it’s probably a bug that only affects Windows 10 machines with Realtek adapters, connecting to Asus routers and using Cloudfare DNS.