Why no SSL

I have several sites and all are https … except the latest (about 2 days ago) and it says active but it is still http and not Https"
the site is learnitwith.us

https://learnitwith.us/ appears to load for me. You can foce all traffic to Always use https" on the SSL/TLS app.

Thanks but all my other sites show up as https but this one still has that warning that the site is not secure?

I’m not seeing any warnings:

Probably completely out of the ball park, but I had same until I completed Cloudflares privacy popup

In Chromium web browser on linux, I’m getting Err_Cert_Common_Name_Invalid:

This server could not prove that it is www.learnwithus.com; its security certificate does not specify Subject Alternative Names. This may be caused by a misconfiguration or an attacker intercepting your connection.

From https://www.xtremerain.com/fix-err-cert-common-name-invalid/#webmaster

What Webmasters can do to Fix Err_Cert_Common_Name_Invalid:
Actually, There are many things to do. Here are some methods.

Install SSL Cert Properly. In case, Your configurations are OK, and you are facing the problem, I recommend you to re-issue the certificate with a new private key. Make sure, Your common name for this cert is correct. Then, Install it correctly.
Sometimes, Your visitors from chrome browser may face different SSL warning messages even if everything is fine in other browsers. In that case, I suggest you check everything more carefully. If your site is based on WordPress, You can try this plugin Chrome SSL Fix for WordPress and see if it works.
In some blogs and forums, Users may get suggestions to disable SSL warning in chrome browser to resolve err_cert_common_name_invalid. But, I strongly recommend you to avoid this practice."

This is just from some quick “googling” (actually Duckduckgo) But the warnings seem to be suggesting that you may be victim of a hacker stealing information from your website visitors. Or it might be a simple configuration problem, although the fact your other sites are working fine casts a little doubt on that. You need to secure your site and make sure no one is stealing personal data from your customers. Sorry I don’t personally know how you go about that. I know enough to know it’s serious, though.

Man, you need to check the always https on SSL/TLS app, then you’ll get the ssl always :sleepy:

Might be some configuration on your site, the ssl rejects by anything that seems strang in the source, try to seeing that.

LOL all were great suggestions but I turned that on and all is good in mudville LOL Thanks to everyone! BTW I have no user data as yet and I am using wordfence which appears to do a good job of blocking…

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.