Why my site keep making 520 error

Hi everyone i’m new here and it’s my first time to use Cloudflare
While i’m trying to access my sitemap it keep making

What i should do?

It’s loading for me. Are you still having this problem?

1 Like

it happened again now Cloudflare Ray ID: 67cc974f8a844075 and i don’t know what i should do?

Before you added the site to Cloudflare, was it working every time with HTTPS?

2 Likes

When i made the site it was with http and i added it to cloudflare but i gone to my domain and added https secure all what i did :smiley:

I don’t get what you mean? And what i should do
My sitemap for my website keep going make errors i need help plz

My server help desk said that

Welcome

Sorry about the issues, we’ve seen similar reports affecting some sites on Cloudflare and are working on a fix

In addition to this Community site, the cf status site is another good cloudflare site to keep handy
https://www.cloudflarestatus.com/

Let us know if the 520’s persist.

My website still getting till now error 520 please help me

We are also still seeing the 520 errors. Has the fix been deployed throughout Cloudflare? Adding Ray ID below if it is helpful to debug.

Cloudflare Ray ID: 67d4285f4ac8057d

1 Like

@user9392 @anuj1 the issues you are seeing are most likely related to this Cloudflare incident that’s currently still ongoing/being monitored:

2 Likes

@cloonan The outage page says that the issue is resolved but that is not what we are seeing. This is really problematic as our entire product is down because of this.

1 Like

If you are still seeing issues now that issue is resolved, it is most likely an error on your server’s side.

A 520 error occurs when the connection started on the origin web server, but that the request was not completed. The most common reason why this would occur is that either a program, cron job, or resource is taking up more resources than it should causing the server not to be able to respond to all requests properly.

Review the Quick Fix Ideas in this Community Tip for troubleshooting suggestions.

2 Likes

Nothing has changed on our end at all and no errors on our server either.

Are you seeing the 520’s on a particular page or from a particular location? I tried a few dozen locations and don’t see any 520s.

Here’s an example: https://shuffle.do/@anuj Everything on our domain both the APIs and front-end are returning 520. Thanks for checking!

Hi
While I’m trying to access for my sitemap
https://www.appsscope.com/sitemap_index.xml
I got the error 520
Cloudflare Ray ID: 67d7a6da88300843

Hey there I can confirm your situation

Here is the trace
https://www.appsscope.com/cdn-cgi/trace

fl=368f100
h=www.appsscope.com
ip=x
ts=1628750221.252
visit_scheme=https
uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.131 Safari/537.36
colo=MIA
http=http/3
loc=CO
tls=TLSv1.3
sni=plaintext
warp=off
gateway=off

The weird thing here is that it mostly happens on websites that starts with www. domains if you go to your domain without www. the server respond accordingly and redirects to www. but when it redirects and reach the destination then appears the error in a random way this is happening not only on free plan users as a stated before by CF but also on paid plans users.

Also this occurs more frequently on sites with SSL TLS 1.3 and QUIC enabled and less frequently on sites with those options disabled (but still happens) you should merge all recents 520 errors post into one.

1 Like

What i should do please?
Open new ticket and post what output from that trace with the cf id?

That must be always the first thing you should do in these situations, You should include the same information (Ray ID from the error page) dates, hour, your IP, and the trace data from the /cdn-cgi/trace and also of course the URL that shows the error.

On the community the help is sometimes limited because there are logs and information that its only available to you and can not be disclosed so the only way that CF team has to check your case is with a support ticket so they can check personally according to your site and CF settings and answer you personally.

However if you find the solution or the root of the problem please share it with the community so everyone can benefit from it.

The ticket system offer you more tools and also offer a way to attach screenshots etc however if you can’t open a ticket (for example if you are on a free plan) then you have to write an email directly or wait for a forum moderator here.

1 Like