Why my domain name not open on mobile phones since I changed my nameserver to cloudflare?

I changed my nameserver to Cloudflare and I noticed my website only opened on laptop and not open on mobile phone. what might be happening? My domain name is bfocuspreneur.com.

I’m accessing this site on my phone and I’m being redirected to cpanel.bfocuspreneur.com is it expected?

1 Like

exactly…that’s the issue. but it will open on your laptop

is not expected…It started since I changed my nameserver to Cloudflare…

Do you have Mobile Redirect enabled in Cloudflare?


I don’t think so domjh

Can you check that?

The redirect appears to be coming from Cloudflare. Also, do you have any page rules enabled in Cloudflare?

>>> https://bfocuspreneur.com

> --------------------------------------------
> 302 Moved Temporarily
> --------------------------------------------

Status: 302 Moved Temporarily
Code: 302
Date: Thu, 14 Feb 2019 16:34:13 GMT
Connection: close
Cache-Control: private, max-age=0, no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Expires: Thu, 01 Jan 1970 00:00:01 GMT
Location: https://cpanel.bfocuspreneur.com/
Expect-CT: max-age=604800, report-uri=“https://report-uri.Cloudflare.com/cdn-cgi/beacon/expect-ct”
Server: Cloudflare
CF-RAY: 4a90f0e4ad5abead-FRA

Another strange thing I notice is that when I try to open your site through a short link e.g.: https://wp.me/P9QBfN-VK it opens fine on mobile.

1 Like

i’m familiar with the short link, how did you get that?

curl -I https://bfocuspreneur.com
HTTP/2 200
date: Thu, 14 Feb 2019 16:29:11 GMT
content-type: text/html; charset=UTF-8
set-cookie: __cfduid=d903f84915b654c3142a1a42fd4c7210d1550161749; expires=Fri, 14-Feb-20 16:29:09 GMT; path=/; domain=.bfocuspreneur.com; HttpOnly
link: <https://bfocuspreneur.com/wp-json/>; rel="https://api.w.org/", <https://wp.me/P9QBfN-VK>; rel=shortlink, <https://bfocuspreneur.com/wp-json/>; rel="https://api.w.org/", <https://wp.me/P9QBfN-VK>; rel=shortlink
last-modified: Thu, 14 Feb 2019 15:52:23 GMT
referrer-policy: no-referrer-when-downgrade
expect-ct: max-age=604800, report-uri="https://report-uri.Cloudflare.com/cdn-cgi/beacon/expect-ct"
server: Cloudflare
cf-ray: 4a90e977dd706587-SYD
1 Like

Great…it has been solved…Bravo! you rock…the mobile redirect was enabled and disabled. Grateful to you.


Glad it is solved! No problem :slight_smile:

well…seems you are just a guru in this line…I don’t know how you got to this place. Though I could see the short link from the codes. I will love to learn more. lol

No rocket science, I was just using curl to check server headers.

1 Like

great! that’s new to my knowledge…Thanks you increase my knowledge just like domjh did…you guys rock.


Where did You check the response? It’d be really helpful to know since curl was returning 200 not 302 :frowning:


I checked with http://www.redirect-checker.org as you can change the user agent. Curl will return 200 on desktop as the redirect was only for mobile.


I see! …Interesting. Thanks for enlightenment

1 Like