Why it is double challange?

Hello, I have a problem with Cloudflare captcha authorization. I have set Javascript Challenge for the country of Poland. For some, this works fine and Javascript is itself, but for some who have, for example, internet from the phone (still IP Polish) it displays 2 challange. Java and challange image. When I turn off JavaScript Challange for Poland, those who had a double challenge would normally go to the site.
I want to set ONLY JavaScript Challange for users from Poland, not double how to do it?

Post a screenshot of https://dash.cloudflare.com/?to=/:account/:zone/firewall?ip=

It is mostly JavaScript challenges but there are also two CAPTCHAs in your list. From these screenshot it would appear as if you had two IP access rules set up, one as challenge and one as CAPTCHA, and both for Poland.

In tools I have only blocked ASNs, no other rules. This is strange, because when I disable this one “JavaScript Challange” rule for Poland, there is no CAPTCHA. When I turn it on, it’s Challenge and CAPTCHA for some people from Poland.
I have only one rule per CAPTCHA and it is

There currently appears to be some issue with the firewall. It is best you open a support ticket.