Why isn't my SSL lock showing in the browser?

ssl

#1

Have you setup Cloudflare SSL on your site but the lock icon isn’t there? Post here and someone should be able to advise on what you may need to fix.


#2

Up! I’m having the same problem. I made the process, including, I installed SSL Flexible in the WordPress of my site. It works by accessing with https:// in front of the URL, but does not show the certificate’s security badge with the lock on the browser’s navigation bar.


#3

Try clearing browser cache? then see if the lock appears. Also try see if this throws anything https://www.whynopadlock.com/


#4

same issue here with my domain https://www.ungeracademy.com
no lock appearing.
here https://www.whynopadlock.com they say there’s a valid certificate.
I had a full SSL certificate yesterday at cloudflare.
today I changed it to full strict for 5 minutes
then moved it back to full again.
could that be the issue?


#5

maybe due to mixed content warnings https://www.keycdn.com/support/mixed-content/


#6

Hi, @eva2000. Many thanks for your insight! In fact, my problem was mixed content. I had forgotten to update the URLs of the images and links from my website, which is working on the wordpress platform. For those who use Wordpress I found a very good solution for updating URLs through this plugin: http://www.wpbeginner.com/plugins/how-to-update-urls-when-moving-your-wordpress-site/


#7

Hello every one,
I’m new to Cloudflare (Only 3 days), and for that reason would like to ask for your help.
I open an account, changed the servers and every thing looks like it is working, my account is showing as active, my SSL certificate is active as well and “flexible”. The problem I have is that on the search engines it still showing as not safe with no padlock. can any one please help me? Oh, I forgot to mention that I don’t really understand much about this things!


#8

https://thebloggercity.com also getting same issue…


#9

bloggercity is looking good to me in Firefox and Chrome. It’s showing the SSL lock with the Comodo/Cloudflare SSL certificate.


#10

So, when I go to my dashboard, it says:
SSL

Encrypt communication to and from your website using SSL.
It may take up to 24 hours after the site becomes active on Cloudflare for new certificates to issue.
Note: SSL certificate issuance may take up to 24 hours.
Status Active Certificate

However, it doesn’t show up when I load the site. What might be happening?


#11

Have you tried enabling the Always Use HTTPS option under the CRYPTO tab in your account? It will make sure that all requests are redirected to the HTTPS equivalent.


#12

I haven’t but when I type https://www.soulevolucao.com.br it doesn’t show a certificate, and I’m directing to the https. Any idea of what’s happening? Do you think my problem might come from the fact that I might have images or links directed on http?


#13

Hey @marco I tried your site and it appears to be using HTTPS - I see :lock: in multiple browsers. Have you tried clearing your cache?


#14

I would try enabling that option and then clearing the cache. Appears to be loading on mine and @andy’s end but just to make sure.


#15

I tried clearing my cache but it didn’t work. I’ll try to ask a friend who hasn’t accessed the website yet. After that, I’ll try enabling the Always Use HTTPS option. Thanks guys!


#16

I even installed firefox on my phone and it still doesn’t work :confused:


#18

The secure lock for my blog https://www.theamitmathur.com/ appears perfectly in FireFox but If I open it in Chrome there is an “i” sign instead of secure lock.

Earlier chrome displayed warnings of insecure content content then I changed all http links to https after this although it stopped showing warning of mixed content but there is no secure lock sign. Not to mention It works flawlessly in firefox , the problem is just in chrome.


#19

Hi there. I checked out your site with Chrome. It looks to be the endpoint for a form you are using.

I cannot explain why this is only occurring in Chrome.


#20

Thankyou so much Andy, I corrected that and now its working perfectly But I checked the source of the page in chrome and found that there are still a few http links but despite them the website is working fine now. Do you have any idea why that just one link was hindering the SSL lock and not these other http links ?


#21

Happy to help! Glad you got it sorted.

Unfortunately I’m not quite sure :man_shrugging: