Why isnt my SRV record not working?

I made an SRV record for a cname which has worked for me in the past on GoDaddy DNS but on cloudflare its not working and is probably something Im doing wrong. How can I fix this?

You can test the record with this tool to help figure out the issue

Share the results if you can, curious as to the cause of the issue you’re seeing.

1 Like

It needs an API token. How would I go about doing that?

How about I share some images of the records?


It looks to me that your SRV points to a record that’s proxied, but trying to use a port that Cloudflare won’t proxy.

If you’re trying to hide your IP address, that’s not going to work, as you can’t hide IP addresses of services that Cloudflare does not proxy.

As a side note, if you proxy a CNAME here, it’s publicly advertised like an “A” record with an IP address that belongs to Cloudflare.

To fix it, that ‘pi’ CNAME would have to be a :grey: “A” record (not a CNAME) with an IP address.

1 Like

Im using ngrok which gives me a domain and a port. Ill just turn off the proxy.

Maybe Im not understanding you but, for the srv to work, I would need to turn off the proxy?

^ That is my understanding, along with record type & IP address

Doesnt seem to be working. Ive used a cname and srv before.

On Cloudflare?

It was when I used godaddy dns but how would it be affected by cloudflares dns?

Because you have proxied something along the way. No host names involved in the SRV chain can be proxied :orange:.

Do you mean the target shouldnt be proxied? If so, the target isnt proxied.

For now, use the Pause Cloudflare on Site option from the lower right corner of the Overview tab. Give it five minutes to take effect before you test.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.