Why is Wrangler so instable?

[wrangler:err] Error: internal error
[wrangler:inf] GET /scraper/checklinkback 500 Internal Server Error (397ms)

No more info? X to exit leads to:
[ERROR] Address already in use (127.0.0.1:9080). Please check that you are not already running a server on this address or specify a different port with --port.

MiniflareCoreError [ERR_RUNTIME_FAILURE]: The Workers runtime failed to start. There is likely additional logging output above.

The last version was OK, but now nothing helps.
NODE LTS + NPM updated to latest version 20
wrangler updated.

Since I am forced to use Wrangler to access Cloudflare services I have to reboot like Iโ€™m running Windows 98.

1 Like

/home/support/.nvm/versions/node/v20.10.0/lib/node_modules/wrangler/wrangler-dist/cli.js:29374
throw a;
^

Error: spawn google-chrome ENOENT
at ChildProcess._handle.onexit (node:internal/child_process:286:19)
at onErrorNT (node:internal/child_process:484:16)
at process.processTicksAndRejections (node:internal/process/task_queues:82:21)
Emitted โ€˜errorโ€™ event on ChildProcess instance at:
at ChildProcess._handle.onexit (node:internal/child_process:292:12)
at onErrorNT (node:internal/child_process:484:16)
at process.processTicksAndRejections (node:internal/process/task_queues:82:21) {
errno: -2,
code: โ€˜ENOENTโ€™,
syscall: โ€˜spawn google-chromeโ€™,
path: โ€˜google-chromeโ€™,

โœ˜ [ERROR] Address already in use (127.0.0.1:9081). Please check that you are not already running a server on this address or specify a different port with --port.

โ•ญโ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ•ฎ
โ”‚ [b] open a browser, [d] open Devtools, [l] turn off local mode, [c] clear console, to exit โ”‚
โ•ฐโ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ•ฏ
/home/support/.nvm/versions/node/v20.10.0/lib/node_modules/wrangler/wrangler-dist/cli.js:29374
throw a;
^

MiniflareCoreError [ERR_RUNTIME_FAILURE]: The Workers runtime failed to start. There is likely additional logging output above.
at #assembleAndUpdateConfig (/home/support/.nvm/versions/node/v20.10.0/lib/node_modules/wrangler/node_modules/miniflare/dist/src/index.js:8889:13)
at process.processTicksAndRejections (node:internal/process/task_queues:95:5)
at async Mutex.runWith (/home/support/.nvm/versions/node/v20.10.0/lib/node_modules/wrangler/node_modules/miniflare/dist/src/index.js:3861:16) {
code: โ€˜ERR_RUNTIME_FAILUREโ€™,
cause: undefined
}

Node.js v20.10.0

@errel sorry youโ€™re running into this issue. We have identified a bug in Wrangler that could be causing this: ๐Ÿ› BUG: workerd inspector process doesn't die ยท Issue #4612 ยท cloudflare/workers-sdk ยท GitHub

While this is being resolved, we would recommend going back to a previous release that worked for you. Sorry about the inconvenience.

1 Like