Why is my WWW CNAME not showing www.website.ext in the url bar?

ssl
cname

#1

I have this domain yeskay.me in Cloudflare and it has a CNAME record “www” that points to “@”. As far as I know, it should show https://www.yeskay.me in the address bar and be the same as the rest of the website. Why isn’t it working that way?

Also, is there a possibility of the SSL certificates being cached by the requesting ISP (My device’s ISP)? Because I can see a “Your connection is not secure” message on all my devices but in Tor, other proxies and other people’s devices the https is working just fine.


#2

Your origin server is giving a 301 redirect for the www to the bare root http://yeskay.me

curl -I http://www.yeskay.me
HTTP/1.1 301 Moved Permanently

Location: https://www.yeskay.me/

Site appear to be served to me over SSL, so could be caching.


#3

How long could it take for the cache to expire? How do i see where the
expiry is set?


#4

If you haven’t made any changes I believe the default is 4 hours (you can check on the caching tab). You can also purge the cache from our side if that help (may also want to clear your browser and DNS depending).


#5

I have purged the cache, and it still doesn’t seem to work.


#6

Which part isn’t working? The 301 redirect is from the origin, so that’s not caching. but the not secure error could be (or at least I’m not seeing the error from my Chrome browser)


#7

www.yeskay.me still redirects to yeskay.me, whilst I want it the other way
around or at least www.yeskay.me have the www in the url and show the same
thing.


#8

The origin server is doing the redirection so you’d need to change the behavior there if possible. I believe the origin you are using only allows one host name, so if possible you might change it there to www.yeskay.me and then you could use a page rule at Cloudflare to redirect https://yeskay.me to the www subdomain.


#9

Yes, thanks that was the problem, I fixed it at the origin and now it works.