Why is my subdomain not possible to proxy?

Hello,

I have problems to route a subdomain through CF Proxy. It is simply not accessible after that. On the subdomain is phpmyadmin installed. No matter how I do it, whether a. “A” entry or “CNAME”, with both the application is no longer accessible as soon as I set proxy to “On” (Orange Cloud). The main domain works fine.

I have already asked in another topic for the “best” option for subdomain. There I was told that if I proxy a CNAME via Cloudflare :orange: no CNAME will be published. In its place, an A and AAAA record will be published pointing to Cloudflare. I would therefore prefer CNAME so that the “real” server IP would not be exposed. But unfortunately it doesn’t work for me (see above).

What goes wrong?

Thanks, PM666

The origin server IP isn’t exposed when a CNAME is :orange:. The IPs in the synthetic A & AAAA records are those of a Cloudflare proxy.

Is your phpmyadmin running on a non-standard port? Cloudflare proxy only works on specific ports.

1 Like

Hello,

thanks, the phpmyadmin is installed on the subdomain via hosters “panel” (LiveConfig) for my VPS where you can install it and some others as “App”.

I have another subdomain (with wordpress installed) what is via CNAME and orange proxy =on and all woks well. So may bee it is because of some reason with these installable apps from my provider/hoster?

Are you attempting to access the application via https://subdomain.example.com/phpmyadmin?
Does this method work when that hostname is set to :grey: DNS Only?
What happens when you try to load phpmyadmin with the name :orange: proxied?

Hello,

YES “grey” (no proxy) works, I can call phpmyadmin but after set to “on” (orange cloud) and with some delay (till settings get active) I get following error message in browser:

Error: Redirection error

An error occurred while connecting to phpmyadmin.domain.com

** This problem can sometimes occur when cookies are disabled or refused.**

Relaods, even Strg+F5 or other use browsers do not work also. Only to “grey” it again brings it back to life. When I use Opera I get more detailed info:

This page does not work
phpmyadmin.domain.com has redirected you too many times.

ERR_TOO_MANY_REDIRECTS

Addendum: With exactly the same syntax for CNAME I can easily call the subdomain of my other domain where Wordpress is installed on this subdomain.

Is your phpmyadmin.example.com loading over HTTPS when :grey: DNS Only?

Yes! It always works with DNS only, https and http (as it is redirected http to https “forced”). It is 2 SSL Certificates existing: One for domain and one for subdomain. Both from Let’s encrypth (via the hoster panel). Can this bee the reason? Because just seen that the other subdomain with WP installation has only one for domain and subdomain (it is via Cloudflare, Keys generated and set into hoster panel).

Problem comes as soon ornage cloud active…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.