Why firewall rule doesn't block Tor country?

I’m using a free plane and added 2 websites with the same configs and settings.
Want to block Tor and use Firewall>Firewall Rules and added the below rules for both websites but it just blocks for one of them and user can browse another one with Tor browser (tested):

(ip.geoip.country eq “CN”) or (ip.geoip.country eq “RU”) or (ip.geoip.country eq “IN”) or (ip.geoip.country eq “PS”) or (ip.geoip.country eq “BY”) or (ip.geoip.country eq “IQ”) or (ip.geoip.country eq “LB”) or (ip.geoip.country eq “SY”) or (ip.geoip.country eq “BD”) or (ip.geoip.country eq “YE”) or (ip.geoip.country eq “UA”) or (ip.geoip.country eq “T1”) or (ip.geoip.continent eq “T1”) or (ip.geoip.country eq “XX”)

I change it to 2 firewall rules and make Tor a separate rule but didn’t work. How can I handle it?
If rules are not correct why work on another website?

“Continent” = T1? I didn’t realize that T1 would work as a continent.

I suggest you use an “Is In” list instead. And make sure it’s the first rule.

1 Like

I tested your solution but it didn’t work

:+1:

I remember I was blocking TOR users using a Firewall Rule which had the expression like:

  • (ip.geoip.country eq "T1")

Nowadays, I switched to blocking TOR (T1) via Firewall → Tools → IP Access Rules.

This option is only available for the Enterprise plan, But the question is why it working on another website and not for this one? Because both of them have the same configs and rules.

Follow the same way how you set up in your first website

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.