Why do I now get the ERROR 1000?

Yesterday I finished setting up my domain to run through CF. It was active and I could access it without an issue. I then tried to add 2 more nameservers at my namecheap cpanel. I did not see that we are only supposed to have the Cloudflare servers only.

Anyhow I now get this error 1000 and I’m not sure how to fix it.

You should’t have to add name servers beyond the two assigned by Cloudflare. So give this a read:
https://support.cloudflare.com/hc/en-us/articles/200171976-Error-1000-DNS-points-to-prohibited-IP

I followed / verified steps 1 and 2. How do I find out if 3 and 4 are occurring?

My Error 1000 started on my two sites 18 Oct out of the blue.

The problem may occur if any of the following conditions is true:

The IP address Cloudflare is pointing to is incorrect.
Pointing your service to another proxy in your zone file. Because Cloudflare is also a reverse proxy, enabling our proxy on a record may create a cyclic loop.
The request includes an X-Forwarded-For header over 100 characters in length
Cloudflare detects a cyclic loop - e.g. Cloudflare proxying back to Cloudflare. This is detected when your origin responds with a “cf-ray” header.

Cloudflare says that emogic.com is 67.212.64.235 on the error 1000 page, but all my dns say that I am 67.212.91.252 (verified my my web host)

Note: I am working on www.emogic.com to try and determine what is happening. So symptoms may vary.
but www.somewhereincanada.com is doing the same thing.

Thanks for the additional information. Your site, as identified by the IP address you provided, is already fronted by Cloudflare. The 1000 is a result of the “cyclical loop” mentioned in the Support article.

Hello CF Team,

Domain name: vinayhegde.info

=======================

  1. Source URL DNS record without Cloudflare
    [vinay@centos-7-docker-machine ~]$ dig vinayhegde.info +short
    139.59.85.222

  2. Source URL DNS record with Cloudflare
    [vinay@centos-7-docker-machine ~]$ dig vinayhegde.info +short
    104.24.98.211
    104.24.99.211

  3. Target URL (Appears to have Cloudflare on their end as well)
    [vinay@centos-7-docker-machine ~]$ dig cakeresume.com +short
    104.25.116.21
    104.25.117.21

[vinay@centos-7-docker-machine ~]$ dig cakeresume.com NS +short
chin.ns.Cloudflare.com.
hal.ns.Cloudflare.com.

=======================

I’m using a basic nginx configuration with the proxy_pass directive to re-direct vinayhegde.info/resume to https://www.cakeresume.com/vinay-hegde which works only when option no.1 is enabled and does NOT work when option no.2 is enabled

I followed the documentation on : https://support.cloudflare.com/hc/en-us/articles/200171976-Error-1000-DNS-points-to-prohibited-IP to disable Cloudflare services post which the re-direction works flawlessly.

I understand this is most likely due to the Cyclic Loop as mentioned by @sdayman & @vpelss but is there any workaround to this? Or is there more documentation to make it more clearer as to why it happens?

Has anybody been able to resolve this without disabling Cloudflare? I am really confused…

Yes…! Just change the A address of your URL/Domain in DNS management inside cloudflare to your hosting IP… Everything will work smooth there after