Why do I keep having 520 error on my website

My website is Amcatholic4life.com. Since I started using cloudflare I occasionally have 520 error anytime I want to access my site. Currently I can’t access my site dashboard because it keeps showing the 520 error. I contacted my host and they say it’s not from them that everything is working well from their side. I have ssl certificate so I don’t know why I keep having this issue please you people should do something about it

Regarding Cloudflare 520 error, may I suggest you to try looking into below articles to troubleshoot the issue:

I have checked and I do not get 520 error so far for now:

May I ask what is your domain name and who is your hosting provider, if so?
Maybe some recent and planned maintenance period at the DC from your hosting provider?

Before moving to Cloudflare, was your Website working over HTTPS connection?
If so, did you had an valid SSL certificate installed at your origin host / server which covers both your naked (root) domain any any other needed sub-domain like www, mail, etc.?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

Regarding available SSL options at Cloudflare dashboard, check here:

If any other issues appear, follow the needed steps for troubleshooting from article below:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare CA Origin Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

1 Like

I can confirm that I meet 520 error on https://amcatholic4life.com/, very often, but not always.

it happen to my site too, vnkeyfc.com, since yesterday, so I do believe there are problems with cloudflare

May I suggest looking into the mine post from above to try to troubleshoot and figure it out?

I am afraid not so really, but we can always check if there is an issue with network here:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.