Why do I always have gateway=off?

I have a few Cloudflare Access Groups that have an include rule (emails ending in: xy.com) and a Require Device Posture: Gateway.
When I’m connected to my Zero Trust organisation and go to https://cloudflare.com/cdn-cgi/trace I allways get warp=off and gateway=off. Same thing when I try to access an application that is in Cloudflare Access with require gateway

In Settings > WARP Client > Device Posture, I have Gateway selected.
In All my Access Groups I have Require Gateway selected
Basically everything that is listed here: https://developers.cloudflare.com/cloudflare-one/identity/devices/warp-client-checks/require-gateway/

What am I missing for it to work?

Okay I got it. It was because I was running a WARP profile with Split Tunnels to include only my companies LAN…
Setting Split Tunnels to Exclude mode works