Why Cloudflare is BYPASSing my custom rule

This is the response. I made sure to ensure there are no “nocache” or similar header, so why it’s getting cached? How do I solve the issue?

cache-control: max-age=86400, public
cf-cache-status: BYPASS
cf-ray: 6d57-BOM
cf-request-id: 07e5s1
content-encoding: br
content-type: application/manifest+json;charset=UTF-8
date: Wed, 27 Jan 2021 14:02:26 GMT
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
expires: Thu, 28 Jan 2021 14:02:26 GMT
last-modified: Wed, 27 Jan 2021 14:02:26 GMT
nel: {"max_age":604800,"report_to":"cf-nel"}
report-to: {"group":"cf-nel","endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report?s=TOv8GJWph%d%d%3D%3D"}],"max_age":604800}
server: cloudflare
set-cookie: ips4_guestTime=1611756146; path=/; secure; HttpOnly
set-cookie: TM_dhdgMjIvd6146547=blob%3Achrome-extension%3A%2F%2Fdhdgffkded96f6b; max-age=15;
strict-transport-security: max-age=2592000; includeSubDomains
vary: cookie,Accept-Encoding,User-Agent
X-DNS-Prefetch-Control: off
x-frame-options: sameorigin
x-ips-loggedin: 0
x-xss-protection: 0

It’s not getting cached. Probably because your site is setting cookies, and Cloudflare won’t cache that because it interferes with the use of those cookies.

@sdayman

Thank you so much. Cookie indeed was the issue. Once I removed it, now it works. :slight_smile:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.