Why Cloudflare adds Last-Modified header to cached html?

This questions was asked before on this topic.

I would like to disable Last-Modified header on HTML pages. How can I disable it?

The blog post in the thread you linked goes over how you can change the behaviour of Smart Edge Revalidation - are you having issues with the methods that they mentioned?

The article said that you need to add last-modified at origin to disable Cloudflare adding last-modified. Now I did not add it this last-modified for a reason and Cloudflare is adding last-modify header because I have not added it.

How to disable it? is there any way to do it. There must be a way.

Smart Edge Revalidation will be enabled automatically for all Cloudflare customers over the coming weeks. If this behavior is undesired, you can always ensure that Smart Edge Revalidation is not activated by [confirming your origin](https://web.dev/http-cache/#response-headers) is sending ETagorLast-Modified headers when you want to indicate changed content. Additionally, you could have your origin direct your desired revalidation behavior by making sure it sets appropriate [cache-control headers](https://support.cloudflare.com/hc/en-us/articles/115003206852-Understanding-Origin-Cache-Control).

any help is much appreciated.

I am able to solve this using page header transformation rules. Thanks

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.