Why can't I connect Domain to Ghost Pro. Ghost Pro/Google expert needed

Hi guys - I’ve been going mad trying to connect my www. site to my ghost.

I initially bought my domain from google domains - and as per guidance on the Ghost Pro site.
I changed the server names on Google to the cloudfare ones.

I’ve then followed the setup guidance for Ghost Pro on cloudfare.

( Ghost pro dont seem to offer any advice on MX ) - if you haven’t figured I’m a total newbie to this game

When I go back to ghost to update the custom domain - it never connects and works out

Any help would be great.

Hmm. I’m not entirely sure what you mean, but let me take a guess.

If I’m correct, you bought Ghost Pro (managed blog software) and would like to use the domain that you bought from Google for the ghost pro website? Then, you’re confused about the mail servers?

If so, you’re going to need to update your nameservers to the 2 nameservers that Cloudflare gave you on their dashboard. You can do this in the DNS section on your Google domains page. Manage domain name servers - Google Domains Help

Then, within a 24 hour window (usually about 2 hours), Cloudflare should tell you that your domain has been linked, then you can start editing your DNS records for Cloudflare.

Here is Ghost’s page for setting up your DNS: Using custom domains with your Ghost(Pro) publication - Tutorial

Once you’ve got that done, as far as I know, email is still managed by Ghost. You’re not hosting the website, your domain simply displays the website that Ghost is hosting, so the email is still managed by them, therefore MX records don’t need to be changed.

Thanks Trent

I’ve followed those steps but Ghost doesn’t seem to like it all.

I would like to keep using the format.
But if I can’t make my dot com work then I might have to bite the bullet and convert to using a wordoress format.

Maybe it’s the fact that when used the custom cloudfare servers I didn’t give 24 hours to be activated.

The struggle continues

Hi @clinicalpinnacle,

My best guess is that you set the CNAME to :orange: instead of :grey: as the instructions suggest.

If that’s not the case, please post the domain.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.