Why am I getting a SSL mismatch error?


#1

Hello to everyone

I have been very happy since I started using Cloudflare. The services and quality of the services I provide are really good, but I have not been able to use Cloudflare since I got the SSL certificate on the web.

Whenever Cloudflare is active, I can not log in to the web site.
ERR_SSL_VERSION_OR_CIPHER_MISMATCH

I have read and edited all the articles on the Internet, but I have not reached the end. Please do not spare your help in this regard

I wish you a good day.


#2

It seems like the device your are trying to access the website doesn’t support the :cert:, probably due to SNI. What browser are you using?


#3

This often happens when your Cloudflare SSL certificate hasn’t finished installing. What is the Status in the SSL section of your Crypto page?


#4

I do not think this is about it. I work in a company’s IT department, and I have knowledge in this regard. I’m sure the problem is something else. I tried 4 browsers and they are all the same.

Chrome
Firefox
Opera
Edge


#5

Hi,

I’ve been waiting for 1.5 days before, but it has not improved. I did it yesterday for about 1 hour as a result of this operation, but the result was the same again. I had to delete the site CloudFlare so that the website did not stay closed.

Do I get the same error every time? Could it be related to SSL? I use Trust Safe SSL.

https://www.isimtescil.net/ssl/en-ucuz-trustsafe-pro-ssl.aspx


#6

You didn’t say if the Status was Active or not. It should look like this:


#7

Clearly I did not mind checking out. But for a period of 1 day, the site was out of circulation and the problem was continuing. I had to cut off the connection with CloudFlare. I will link the web site again with CloudFlare tonight, and I will let you know.


#8


#9

Are you using the Free Universal certificate, or one of the paid Dedicated certificates?

Since this has already taken a couple of days, I recommend you open a Support ticket so Cloudflare can review your situation. Email them: support AT cloudflare DOT com

Or https://support.cloudflare.com/hc/en-us/requests


#10

I have specified the certification I used in the above comment. I use trust safe pro ssl. Paid SSL. I will wait for a few more days and notice.


#11

That won’t work on Cloudflare’s Edge… You must have Universal SSL (default and free), a Dedicated Certificate (bought from Cloudflare at 5/10$ per month depending on the type) or upload yours (only if you are on the Business Plan or higher).

You can use whatever certificate you want for your origin (self-signed, free origin certificate from Cloudflare, third-party) but that won’t be visible to the users.


#12

I’m still confused. It really looks like you’ve paid for a certificate here. Can you post a screenshot of this section of your Crypto page?

If it’s a Dedicated certificate, one option is to click “View” for that certificate, then Delete it. And then re-install it. You’ve already paid for it for the month, so there’s no extra charge to delete and re-issue.


#13

This topic was automatically closed after 14 days. New replies are no longer allowed.