Which records to proxy

Hi
I was told to turn off all the :orange: to :grey: as I was having an issue with the email service not working as it had teh same domain name in the DNS listing as the site. If there is a way to get that working I can turn them back on.

Anything that is supposed to receive emails cannot be on :orange:. Everything that is exclusively used for HTTP related communication can be.

OK, so when I change the settings from the top to the bottom, and only have :orange: on the http based ones, my mail SMTP goes out on my machine and I can’t receive mail anymore.
Any clues?
32

SMTP is used for sending, not receiving. With above’s configuration you should be able to send just fine. Receiving is a different issue and you probably have configured one of the proxied records as server in your client.

Hi

I guess this is the issue.
If I add anything else other that that as at the hostname the mail doesn’t work on a external application.
I will contact the ISP and ask what the solutions are.

29

You could unproxy the record in your DNS settings too.

Hi
Not being a web wiz I don’t really understand too much about doing anything correct with DNS. Could you explain more so I understand how I would do that?

Thanks
I’m using Wordpress as I lost track of the technology :slight_smile:

Simply switch the record in question to :grey:. You should be aware though that all of this will reveal your IP address and you will lose the security and performance features of Cloudflare. You’ll use them basically for DNS only.

Hi
I have them all switched to :grey: now, as like I said before, the other way, was causing issues with my mail. So, basically I guess I am only able to use Cloudflare as a new DNS router instead of my ISP. :frowning:

This topic was automatically closed after 31 days. New replies are no longer allowed.