Where is the option to use IPV6 for A records instead of IPV4?

Where is the option to use IPV6 for A records instead of IPV4? I had to get a new cable modem and when I called my ISP to activate it they gave me a new IPV6 address for my WAN address instead of the old IPV4 address. When I asked them to please give me my original IPV4 address they said they no longer give out IPV4. So now I have an issue since cloudflare is using my old IPV4 address and when I go in to change it to the IPV6 address it says IPV4 is required. How do I fix this prblem?

Please help.

A records are IPv4
AAAA records are IPv6


Thanks for that info. Was not aware. So I have now added all AAAA records for the old A records and then removed the A records. Is there a way to test that these records are actually working?

Actually, the burning question is now that I have these records in cloudflare, when they arrive at my IPV6 Cable modem, How does it translate the IPV6 into IPV4? I have port forwarding enabled on my new cable modem which forwards all SSL traffic to my Kemp LM. But as far as Clouflare is concerned, when I go to my web server it give me a host error and never connects. This all used to work perfectly on IPV4.

You could check what happens when you directly try to access the IPv6 Address.

But keep in mind: you dont Do normal Port-Forwarding with IPv6 anymore normally. You dont need to NAT anything. Your Router will get an IPv6 Prefix and will assign any device on Your Network an IPv6 address when they Support it. So the IPv6 Adress of Your Server will differ from the Router IPv6

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.