Where is Diagnostic center test

I can’t find the Cloudflare diagnostic center test anywhere? The page where you enter the website url and it runs tests to tell you what configurations are not correct. Did Cloudflare take that away?
I am on the free plan if that helps, I used it before but not I can’t seem to find the page anywhere.

Hello there,

This is the one: Diagnostic Center

It doesn’t show a place to test your Website, I only see the documentations of browse by topic, product and or resources. I can’t find the link to enter your website URL to test what’s wrong with my Website.

I see the diagnostic center url has been redirected to support page. I’m not sure why. We’ll leave a update when its available or other members will post here. Alternatively, you can post a article if there’s any issue specifically, the community can reach you to help.

I just need to access the diagnostic center , due to an issue when I enable proxy on a single A record it causes my website to show a “ unavailable page“ instead of the homepage. If I use www before my domain name it works perfectly fine. When I turn off or pause Cloudflare on my website everything works completely fine.
I checked with hosting that all my dns records are correct with the correct IP ADDRESS, the settings for SSL are correct as well.

Please post a screenshot. It sounds like it’s proxied to an old provider, in which case, take a look at Liberate The Hostname in this article:

I haven’t switched providers, I have created my website from dreamhost and still am using dreamhost. The only thing I have done is switch from shared server to a VPS. My host names I haven’t changed tho, I have updated the dns records to the correct IP ADDRESS when I did switch to a VPS.

That shouldn’t have changed anything, unless Dreamhost has some sort of Cloudflare integration I’ve not heard of before (or forgotten about).

What’s the domain?

my domain is lizzyslizards.com. My Website only works when searched by www.lizzyslizards.com when Cloudflare proxy is activated. Cloudflare is currently paused on my Website for my hosting Service to do more tests. I have tried everything. I do not have any page rules set up , although I have tried many page rules configurations to see if I could fix the issue , however non of them worked so as of now I don’t have any page rules. It has to be something with Cloudflare as when I pause Cloudflare the issue is no longer there and “lizzyslizards.com” is completely accessible when Cloudflare is not connected to my Website. Do I need any Specific dns records for Cloudflare to work when proxied?

@lizzyslizardss

You need A record to point at Cloudflare which needs to be proxied. When the site is added, usually the records are auto fetched by Cloudflare.

What would that A record be? Would it be a certain IP address or something?
All my current A records are points to my dreamhost IP addresses.

This sure sounds like it’s on a previous host’s account. It looks like I already posted the link to the solution. Please read it again:

The IP address in all the dns records are pointed to the new Server, at dreamhost they have a automatic transfer system that makes me not have to do anything. However I did just contact them and asked them as well as referenced and linked that article you had mentioned. They haven’t replied yet , hopefully that is the reason and can be solved although personally I don’t think its the reason because of the automatic transfer.

I got in contact with the server specialist on dreamhost, I had sent them the link you had provided. Dreamhost was able to run tests on my website and found “ Checking the site we confirmed that the proxies are currently up, And also noticed that the site loads WITH www, but not WITHOUT. Running tests the site redirects to the www without the proxy, But it does not when Cloudflare is factored in“
Basically they had found nothing is wrong on dreamhosts end , and recommend checking
settings with Cloudflare and see what’s causing the discrepancy between the non www and the www version of the site.

They also mentioned the link/page for HTTP ownership_verification no longer exists.

I have no idea how to fix it , I might have to use a different CDN service and delete Cloudflare altogether. The Cloudflare customer service for the free plan is absolutely absurd. If can’t get into contact with their customer service to get the actual service to properly work , why waste my time trying to fix it and end up messing it up even more . It’s quite frustrating.
Please let me know if you have any other ideas that might be causing this issue, any settings I need to check ?
Thank you for your help!

@lizzyslizardss

Does it work when its not proxied?

@lizzyslizardss Here’s the loophole I find. You’ve the DNSKEY record for lizzyslizards.com, but there’s no DS record. You can check it here:

Yes my website works perfectly fine if I turn off Cloudflare proxy.

I’m not sure how I have a dnskey record, dnssec is not enabled nor is it in process on Cloudflare.
I don’t see any record in my actual dns on Cloudflare or dreamhost for dnskey. I don’t want to enable dnssec , if this is what’s causing the problem, how do I remove it?

@lizzyslizardss Here’s the reference:

@lizzyslizardss

Remove from your host.