Where do i enable websockets i checked the documentation and it out of date

What is the name of the domain?

mingnint.xyz

What is the error number?

i don’t get one

What is the error message?

doesn’t exist

What is the issue you’re encountering

can’t find where to enable websockets because docs are out of date

What steps have you taken to resolve the issue?

post here

What are the steps to reproduce the issue?

zero-trust

You don’t need to enable web sockets specifically, they run over the normal HTTP(S) connections.

There’s also the regular Websockets setting for individual zones:

1 Like

i have enabled websockets but i still can’t connect the websocket server is running on port 5000
i have made the tunnel for it just going to HTTP://localhost:5000 but I can’t connect

Is that on by default? I can’t remember ever activating that.

Make sure you connect to Cloudflare on port 80/443, or any of Cloudflare’s supported ports. Your backend should be fine with port 5000, but not the frontend.

1 Like

i still can’t connect to it at ws://chat.mingnint.xyz:80 or 443

It is. Test zones I’ve never made Network changes to have it enabled.

so do you know how to fix my issue?

I don’t really have an idea. I never had any problems using websockets with a tunnel.

My tunnel points to https://localhost:443 where I have apache listening.

When I opened chat.mingnint.xyz yesterday, I got a 426 - Upgrade Required error, so I assume the HTTPS requests were reaching the server. Can you look into your logs and confirm that requests are not reaching it?

1 Like

i managed to fix my issue with the websockets

2 Likes

Could you maybe share how you fixed it so that other people with the same problem might benefit from your solution?

1 Like

i changed from using ws:// to using wss:// after trouble shooting with wscat

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.