Where can I see the status of my SSL certificates?


#1

I’ve added a new domain (skillsmatter.com) to CloudFlare. I haven’t switched over nameservers yet, but I’ve tried it both by modifying my /etc/hosts file and by configuring my local DNS servers to point to CloudFlare - and in both cases, I get ERR_SSL_VERSION_OR_CIPHER_MISMATCH.

Checking the ‘Crypto’ settings for my domain, I can see a reference to ‘your certificate status above’ - but no idea what it’s referring to. It’s been over 48 hours now since I added the new site to CloudFlare and I have no idea what’s going on… can anyone point me in the right direction?


#2

Ya that is weird… When I run sslscan on it it shows no supported cyphers… In the crypto tab there are settings for “Minimum TLS Version” and “TLS 1.3”. What are those set to? Also are the customized using page rules?
Maybe I have the wrong IP. What is the name of one of the cloudflare nameserver you got?


#3

Our CloudFlare nameservers are

They are resolving skillsmatter_dot_com to 104.18.32.75 - this is the IP I’ve configured in /etc/hosts to test the configuration.

Minimum TLS version is set to 1.0

TLS 1.3 is Enabled.

We have not created any customised page rules.

Any ideas?


#4

Not really sure… Might be a good idea to ask cloudflare support
Hmm… one thing that might prevent certs from being generated are CAA records… but you don’t seem to have any of those… and if you did cloudflare would kind of add the things it needs to add automatically to get it to work.
Edit: though it wouldn’t be able to add the records it needs if the name server isn’t set in the registrar… but it’s a moot point since you don’t have any CAA records…