When using development mode it shows recent uploaded image otherwise old image


#1

I’m having some problems with my website, my CMS provider told me it has to do with cloudflare settings and cache. Therefor I used development mode to bypass the cache and indeed now I can see my latest uploaded image (logo). Also, some buttons (functionalities) previously worked and now not anymore, development mode didn’t resolve this issue. Additionally the buttons (functionalities) still work in safari but not anymore in chrome. Clearing all cache in Chrome didn’t resolve it. What might be possible to resolve with settings on cloudflare?


#2

Some filetypes stay in cache for a while. You can clear the Cloudflare cache under the Caching tab. You can Purge Individual Files, or Purge Everything. I usually Purge Everything because I’m too lazy to type in the exact path of the file, or I’ll type in the wrong thing. The cache will rebuild as visitors hit your site anyhow.

As for the buttons, someone reported that Rocket Loader here might disrupt some Javascript. You can disable Rocket Loader under Cloudflare’s Speed tab.


#3

Thanks it worked!