When using CloudFlare IPFS, non-HTTPs non-www URL does not redirect to HTTPS version

I have also tried adding a page rule for “Always use HTTPS” as well as “Automatic HTTPS rewrites”

Why is the non-www version not redirecting to HTTPS when visiting http://popswap.org directly?

I am going to implement a JS-based redirect in the meantime but I would really appreciate any help with this.

You have a Page Rule for www to redirect to yourdomain.com, but may I ask have you got an A www record at DNS tab of Cloudflare dashboard for your domain?

From the screenshot above, you have only CNAME popswap.org, but I do not see any www here.

Kindly, add a new CNAME www (name column) and point it to @ (content column).

Moreover, from the screenshot above, it’s only DNS mode and I am concerned that Page Rules or any other settings at Cloudflare do not have an influence on your domain (not being :orange: - proxied via Cloudflare?).

Regarding the Page Rule, it should be the:
www.popswap.org/* with “Forwarding URL - 301 Permanent Redirect” option and the value of https://popswap.org/$1 (meaning redirect each request from www to non-www domain)

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.