When trying to add site I get "Invalid Domain"

When I try to add my domain name on the “add site” page, the site tells me that it is an “Invalid domain”. My site is https://www.cryptologe.nl so I put that in, tried it without the www and even as simply cryptologe.nl .None of them work. I cannot add my site. The site is up and running. What could be the problem?

Hi there,

In order to add a domain to Cloudflare you need to define the root/apex domain wihout the http/s schema - so you would need to use cryptologe.nl when add site, nothing else. Can you ensure there is no whitespace and the beginning or end of the domain and test again?

2 Likes

This worked! Thank you.
Now Cloudflare is asking me about DNS. I’m just a starting website owner! Should I just click continue and all will be done automatic or will my website explode if I hit it?

It should work just fine as it requires you to do a couple of changes before taking over, clicking continue doesn’t actually do much.

Make sure you have a fully working HTTPS setup, as it seems you do, before doing changes.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.