When I want to change the NS on the registrant (Afrihost) I receive an error

When I want to change the NS on the registrant, I receive an error:

Oops! An Error Occurred
We checked and we failed to find any NS records for branvery.co.za at the server [Cloudflare Nameserver]
Please double check that you have entered the correct name server and you have correctly configured the server with for your domain

Indicating that more needs to happen on Cloudflare side.

The exact same issue was logged earlier, but with no assistance, and it was auto-closed:

When I want to change the NS on the registrant I receive an error

As part of doing the due diligence and reaching out to Afrihost, I got the response:

Good Day Daniel

We have tried adding the nameservers as requested and it is giving us an error stating that the domain hasn’t been linked/added to those nameservers on the external hosts side, please be sure that the domain is added to their DNS cluster so we can assist with updating the nameservers

Awaiting your response
Thank you

We now have a stalemate, any advice?

  • I have no other options on Cloudflare
  • I have no way to update the DNS, as Afrihost refuses

From your error message, I would assume you are trying something other than changing your nameservers.
Can you post a screenshot of the menu where you are trying to accomplish this?

There should be nothing to prevent you from changing the nameservers into whatever you want, the process does not involve the target at all.

1 Like

Sure, I am adding it as per their Control Panel, and have asked their extensive support team to assist, to no avail.

Please correct me if I am an idiot, but I think I have the right place (included in the screenshot below:
image

1 Like

From what I see, it seems you are in the right place.

This is very strange, because there is absolutely no reason that the Cloudflare Nameservers should have NS records for your domain.

You are not the first person with this problem at Afrihost, When I want to change the NS on the registrant I receive an error - #2 by fritex seems to be in exactly the same position.

I would assume this to be a bug in their system that they need to fix. They shouldn’t be checking anything in the first place.

1 Like

Thank you @Laudian, I will escalate it back to Afrihost. This definitely seems to be an issue on their side.

Should there be a resolution, I will happily post it here as a guide for the next person struggling.

Open to trying anything else in the meantime if someone has a suggestion.

Nothing more from Afrihost, their support has gone dark. So I am publically keeping it alive here, and sharing the outcome, as that is not how client service should be handled.

I am sending a new request to Afrihost, based on what I received the following from Cloudflare:


We could not add the website xxx to your account because your nameservers (NS) are not yet pointing to Cloudflare.

Update your nameservers

1. Log into your registrar
Find instructions for your specific registrar (support.cloudflare)

2. Update your current nameserver records with the ones we have assigned:

  1. archer.ns.cloudflare
  2. novalee.ns.cloudflare

Only these two Cloudflare nameservers should be listed at your registrar. All other nameservers must be removed.

The Cloudflare Team

Round 1: Starting Proceedings

So, I got a response from Arihost, a nice chap called Shadei:

Apologies for the inconvenience caused.

Kindly note that the error we are getting is because the domain is not on Cloudflares DNS cluster.
The domain is on the Cloudflare Dashboard, but it needs to be updated on their cluster.

Once it is added, as soon as we submit the nameservers you have provided, it will update successfully.

Kindly check if the below link works to add the domain on Cloudflares DNS cluster.
Link: Deprecated - Step 1: Adding your domain to Cloudflare

Looking forward to your response.

Never one to give up, my response was that I had done this, and that was what got me into trouble in the first place. Overly confident, I also added that I believe the issue remains on their side… boy was I wrong.


Round 2: Sweet Somethings

The response was courteous as ever and along what I perceived to be the lines of “have you switched it on an off again”:

Apologies for the inconvenience caused.

Was the Domain added less than 48 hours ago on Cloudflare?
Once the domain is added on Cloudflare, we will have to wait about 48 hours before adding the nameservers.

If it has been longer, I would recommend contacting Cloudflare to remove your domain and re-add it to their Cluster so that it successfully updates.

Looking forward to your response.


Round 3: Humble Pie

My response was less than enthused, and borderline mean (remember that for later). Ever the fool, I deleted the site on Cloudflare and re-added it.

However, this time around there were more DNS records… time for humble pie.

Turns out that the first time, not all records were picked up by Cloudflare from Afrihost:


[ Exhibit B: New DNS records ]

Now, I trust that the TXT records mean nothing. However, that lone A record … could that be the culprit?


Moving along swiftly, the Afrihost Name Servers were updated without a hitch, and we seem to be golden.

Sollution
For anyone struggling - simply deleting the site and adding it back to Cloudflare worked fine. I suspect the missing A record may have been the issue, it is, after all, the only significant difference.

So if you get stuck, try it - that might just save you 4 days, many messages to Afrihost, and some egg on your face.

With humble apologies to Afrihost.

There is nothing to apologize for. That this record is required to change the nameservers (if it is actually the case) is simply a bug in their system that they need to fix.

Changing the nameservers is something that happens entirely on their side. If they are checking for existing A records on the new nameservers before changing them, they definitely shouldn’t be doing that.

If you wanted to change your nameserver to pink.elephant, they should do that, despite pink.elephant not even existing.

I think this is some misguided attempt to protect their customers from breaking their websites by not adding the correct DNS records at the new nameserver provider.

3 Likes

I’m currently dealing with the exact same issue with Afrihost. I’ll try your suggestion of re-adding my site on Cloudflare.