When I type my domain in the format www.mydomain.co.uk it is not showing

I have recently added Cloudflare to my website feelingishealing.co.uk. The SSL certificate appears to now be working. However when I type my website in the format www.feelingishealing.co.uk, it is now coming up with an error message. How do I fix this please?

You probably need a DNS record for the www subdomain.

Currently there are no DNS records listed for www.

If it used to work when the domain pointed straight to the hit rather than through Cloudflare then you may need an A record for www pointing to the server IP or may need a CNAME for www pointing to the root domain depending on your setup.

How do I do that please?

Try creating a CNAME for www.feelingishealing.co.uk pointing to feelingishealing.co.uk in the DNS tab of your CF dashboard and see if that works.

If not, try deleting that and creating an A record for www.feelingishealing.co.uk pointing to the same IP address as feelingishealing.co.uk

The CNAME option worked, thank you!

No problem, glad it worked for you.

This topic was automatically closed after 30 days. New replies are no longer allowed.