When I put the CF DNS my web stopped working


First of all, thank you all for forming this wonderful community.

The point is, my website worked fine before I started to use CF. When I verified my website changing my domain DNS suddently stopped working and show me a generic plesk page.

My host config: Host NS, regular DNS (no change)

My domain config: CF NS (changed Host NS to CF NS)

My website is: www.nextlevelgamingstore.com

I also changed between SSL flexible, strict, etc. But didn’t worked :frowning:.

Did I do something wrong?

Here is a screenshot of my DNS table in CF.

DNS is resolving fine for me. Condensed dig +trace:

nextlevelgamingstore.com. 172800 IN     NS      guy.ns.cloudflare.com.
nextlevelgamingstore.com. 172800 IN     NS      violet.ns.cloudflare.com.
;; Received 747 bytes from in 50 ms

www.nextlevelgamingstore.com. 300 IN    CNAME   nextlevelgamingstore.com.
nextlevelgamingstore.com. 300   IN      A
;; Received 87 bytes from in 19 ms

DNS is the only thing you’re asking Cloudflare to do, based on your screenshot, so the issue must be on the hosting side. I’m getting a default Plesk site. I assume that is not what you expect? Maybe some issue with virtual host setup?

Also, are you sure the IP address is correct? Looking at a history of DNS for that domain, and querying the old DNS servers, it seems like was the address. Did you make a typo?

$ host www.nextlevelgamingstore.com ns1.aurorahosting.es
www.nextlevelgamingstore.com is an alias for nextlevelgamingstore.com.
nextlevelgamingstore.com has address
nextlevelgamingstore.com mail is handled by 10 mail.nextlevelgamingstore.com.

Didn’t touch anything but you are right its pointing to 245 instead 246.

I changed them

but TOO_MANY_REDIRECT error appers.

This are my hosting DNS.

And thank you for your reply.

Looks like it is working now and is going through Cloudflare: https://webpagetest.org/result/200325_HP_4e07346742f022b6364d9f2a00f554db/

It might take some time for the DNS changes to propagate, though!

Thank you!!!
You really solved my issue. It was the wrong asignned IP.

Hi. I’m also facing the same issue with my site (burhanicustoms.com). Since joining it has been 2 days. I can’t access my site on mobile. I tried different SEO tools to check my site and all returned DNS errors. What could I be doing wrong?

This topic was automatically closed after 31 days. New replies are no longer allowed.