When i enable all DNS and PROXY my site gets really slow!


#1

I have a problem here!
As soon as I enable all the DNS so they turn orange the site gets really slow the loading wheel keeps spinning for like 10-15 second. But the site if fine when all the dns is greyed out? What can be the problem here?

The site is also fine if I turn down the security to essentially OFF.

This is what i get from www.webpagetest.org

URL: http://www.helicam.se/wp-includes/js/jquery/jquery.js?ver=1.12.4
Loaded By: http://www.helicam.se/:12
Host: www.helicam.se
IP: 104.18.40.167
Error/Status Code: 522
Priority: MEDIUM
Request ID: 28973.5
Client Port: 49558
Request Start: 0.207 s
Initial Connection: 29 ms
Time to First Byte: 15568 ms
Content Download: 1 ms
Bytes In (downloaded): 0 B
Bytes Out (uploaded): 0.4 KB


#2

It looks generally speedy to me from Chrome’s Dev Tools, but a final script loads way after the rest of the content.

Are you running Autoptimize? I’d experiment with the following:

  1. Turn Autoptimize off
  2. See if Rocket Loader is enabled at Cloudflare under the Speed tab.

#3

Yea but the strange thing is that chrome dev tool doesnt recognize it. If you try the site at www.webpagetest.org you se another thing I see on the site. Its a huge diff in loading time between the 2…

And yes im using autoptimize and also wp fastest cache. And the site is super fast when all DNS are greyed out…


#4

It takes around 10 seconds just for the server to respond when i activate all the DNS and Proxy…


#5

Two out of Three runs were fine. The last run was awful.
http://www.webpagetest.org/result/171104_VK_c6d15e952d8e45bccb0b5353d9cb51cd/1/details/#waterfall_view_step1

I’d open up a Support Ticket and show them the above results, as it’s definitely out of whack.


#6

Look what i get.

https://www.webpagetest.org/result/171104_J3_340429945d27378cae810eee0d74126d/

If I enable rocket loader it loads faster but the page gets screwed some of the functions…


#7

where to i file a support ticket?


#8

support.cloudflare.com or email them at: support AT cloudflare DOT com from your account’s email address.

Judging from your webpagetest link, at least it’s consistent across all three runs. The 522 shows the server timing out, which is odd since everything else looks good. I don’t use Rocket Loader because 1) As you’ve noticed, it can interfere with some aspects of a site, and 2) it’s unnecessary when running HTTP/2 (see below).

It also looks like you’re running WP Fastest Cache, correct? I use that one as well, but turn off all minification and such. Cloudflare can minify the same resources if you enable it from Cloudflare’s Speed tab.

I also use HTTPS. 1) It’s secure, and 2) Cloudflare uses HTTP/2 which does a better job of loading resources in parallel, though webpagetest only tests HTTP 1.1, so the benefits don’t show up there.


#9

Yes im using fastest cache and also autoptimize

Ok yea maybe I should try and configure it for https its just that it seems hard? you have any advice there?


#10

Who’s your host? They often have an option to switch HTTPS on.


#11

ah ok its binero from sweden, I have to check it out


#12

Can it be something with an out of date jquery.js. Its ver=1.12.4

https://www.webpagetest.org/result/171105_9R_967c18a93fd7a8ff6007fe568fb179fc/1/details/#waterfall_view_step1

Look at this test


#13

Hmm when i changed server to Poland i got this…

https://www.webpagetest.org/result/171105_K2_ca6e1e93abbd3fcbe279c780492c893f/


#14

That jquery request wasn’t cached. It’s supposed to be. Do you have any Bypass cache settings or page rules?

One other potential issue is that Autoptimize serializes filenames, which won’t get a cache hit if that number keeps changing. I’d turn Autoptimize off for now. WP Fastest Cache should do enough for site speed in conjunction with Cloudflare’s caching.