When I add cf.bot_management I get an error

When I add any cf.bot_management I get this error “not entitled to use bot_management field(s) in expression, at index: 0”

(cf.bot_management.score eq 2 and not cf.bot_management.verified_bot and http.host contains “xxxxxxxxxxx.com”)

It seems like Cloudflare’s Page Rules are displaying options that are reserved for higher tier plans. I don’t know if this is something new, but it’s come up twice today.

Maybe @mdemoura is around today and can chime in on this, as well as the geo-continent check now showing up on the firewall builder for free and pro plans.

1 Like

@shanlin52, those Firewall Rules fields are likely not available on your plan:

Access to the cf.bot_management.verified_bot field requires a Cloudflare Enterprise plan.

The other ones require a Bot Management subscription.

1 Like

It’s interesting that those show up in the dropdown on free plans. Only a trip to the developers documentation explain the limitation. It would be nice if it was greyed out/unclickable if not allowed on that plan.

How about ip.geoip.continent? Someone got the same Not Entitled message, and the Developers docs don’t mention that limitation.

I don’t see any logic for not being able to use the option by continent in the firewall rules when the other options are enabled in special countries. I guess there is still a mistake to correct?

This topic was automatically closed after 30 days. New replies are no longer allowed.