What's wrong with my TXT records (SPF/DKIM)

Hi,

I’m struggling with my DNS records, especially the TXT records for DKIM and SPF.
I don’t see them with nslookup or dig.
I’ve read a lot in the forum, checked my records a million times, tried every lookup syntax, but I’m still not sure why I don’t see TXT records. It’s either that the records are wrong, or I’m just confused how to show the records outside the Cloudflare.
I’m pretty sure that I’m missing the obvious and I could need some help from the experts.
I’ve attached one of my records.

Thanks,

Rudi

Rename them to “default._domainkey” and “@”.

If you are sending mail as [email protected] your TXT record is correct. If you are sending as [email protected] the TXT record should be for @ as @sandro mentioned.

@sandro @cscharff thanks to both of you. You are really quick :-).
I’m not gonna tell you how many hours I have spent before I posted this question.

I have changed them both as per you advice and I can see the SPF now, but I don’t see the DKIM.

I use the following commands to look at the entries:
dig @1.1.1.1 +nocmd smartfriday.nl txt +noall +answer nslookup -type=txt smartfriday.nl

Any suggestions?

image

For the DKIM record you have to query default._domainkey.smartfriday.nl.

You beat me to it!. I remembered that I read that somewhere and I just tried it.

Thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.