What is r.eaburl.com?


#1

I have been using 1.1.1.1 for a month now and have begun noticing all my external links from facebook to run from this:

Facebook.com/* -> r.eaburl.com/* -> domain.com/*

Any attempts to google this domain lead to no information someone like me can even use, if any information is available… seems very scarce.


#2

Example of a URL

https://r.eaburl.com/?key=a982cfabb5482be54a4d3a52b21940d7&u=http%3A%2F%2Ftry.kidbox.com%2Fwelcome1%3Futm_source%3Dfacebook%26utm_medium%3Dcpc%26utm_campaign%3DProspecting%26utm_keyword%3D5LAL%26utm_content%3DUGCSlideshow%26fbclid%3DIwAR3Lq2J5JCkw_GtfEoGXDX4nNtPHAd6h5nytYaXOG3Hx0YqiJ192GHujQ3M&cuid=eab-f


#3

And how is that URL related to Facebook or Cloudflare’s DNS?


#4

Looks like an affiliate link but this has nothing to do with cloudflare.
Change back to 8.8.8.8 and try again and Don’t forget to clear the browser cache before.
Check your PC for any adware, malware, or what ever if it persists after you changed the DNS.

This domain is regisered with Namecheap and the root is redirecting too google which
strengthens my feeling that this is something local.


#5

Adding r.eaburl.com to my hosts as localhost/127.0.0.1 did not “stop” this from happening, scanned computer, changed dns, ran ccleaner… safe mode… nothing stops it?


#6

What should that stop? It is still not even clear what the issue is.


#7

It should be clear: when browsing facebook… all external links start like so:

Open new tab with URL pre-determined as: r.eaburl.com/* and almost instantly go to their destination that’s inside the URL below:

https://r.eaburl.com/?key=a982cfabb5482be54a4d3a52b21940d7&u=http%3A%2F%2Ftry.kidbox.com%2Fwelcome1%3Futm_source%3Dfacebook%26utm_medium%3Dcpc%26utm_campaign%3DProspecting%26utm_keyword%3D5LAL%26utm_content%3DUGCSlideshow%26fbclid%3DIwAR3Lq2J5JCkw_GtfEoGXDX4nNtPHAd6h5nytYaXOG3Hx0YqiJ192GHujQ3M&cuid=eab-f

As you see there is a URL there, and it follows within 1 or 2 seconds of opening…

This problem only occurs on facebook


#8

Do you have any browser plugins for Facebook installed?


#9

Well, it isnt / wasnt. Particularly because 1.1.1.1 cannot be responsible for the issue you described.

As @MarkMeyer already explained your computer most likely got some malware in some form installed (could be also an extension, as @sdayman mentioned) and you need to clean that up.


#10

Do you have Easy AdBlocker?

E(asy)A(d)B(locker)url


#11

Actually yes… i use 3 adblockers and that is one of them… sounds like that’s the issue, thanks!