What could be the reason, that TLS verify doesn't work for my tunnel?

Hi

I have created a tunnel for nextcloud.miracuru.ch.
There is running a nginx webserver with certificates from Let’s encrypt running and hosting my Nextcloud instance.

The certbot on this server places a DNS challenge in my DNS records to be able to verify that I own the domain. This has worked and I have a valid certificate for this subdomain.

I have also verified that the creation of the tunnel has correctly placed a cname in my dns records and this worked too.

My “Your SSL/TLS encryption mode” is set to full. Not sure if it should be strict. I tested it shortly. But still had no success.

Unfortunately, I can reach my nextcloud instance only, when I disable TLS verify in my tunnel. Otherwise I get only a 502 Bad gateway.

I have currently no idea, what could the cause be.

Best regards

Simon

I found the error. The issue was, That I have used Let’s Encrypt certificates. I tried afterwards using Origin Server Certificates from Cloudflare and then it worked immediatly.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.